GuildWiki has been locked down: anonymous editing and account creation are disabled. Current registered users are unaffected. Leave any comments on the Community Portal.



older discussions[]

Just as a note, there is another command line used to show FPS and a little more info. I don't remember it off the top of my head, but I'll fill it in when I get home if no one else does before then. --Rainith 03:17, 3 November 2005 (EST)

I added the FPS option for the shortcut. Is "Command line" the best name for this? --Curtis E Bare 12:48, 3 November 2005 (EST)

I named it 'Command line', but that was more or less the first thing I thought of (and incidentally suggested in GuildWiki:User Questions. It's not terrible (since this is command line stuff), and it's at least as good as "Shortcut options" or anything like that that comes to my mind. Any suggestions? --JoDiamonds 05:34, 3 November 2005 (EST)

I suggest "command line options" or "command line parameters" --Karlos 08:56, 3 November 2005 (EST)
For what it's worth, I specifically avoided those as they seemed too specific (and there's options/parameters/arguments/etc.). And should there be any other information we want to provide about the command line for Guild Wars besides options (such as how to launch the game from it), it seemed like these things should all be on one page. I don't feel strongly about any of this, though. --JoDiamonds 09:08, 3 November 2005 (EST)

Does the "-email" option work? At least I didn't manage it... --Eightyfour-onesevenfive 16:42, 26 February 2006 (CST)

It works for me. -- 04:43, 28 March 2006 (CST)


What is the default heapsize setting? Someone with a better understanding should label that setting with what effect the setting has on your gameplay. -- 04:43, 28 March 2006 (CST)

-dx8 not working[]

I have had this in my shortcut for ages, but it has now stopped working. The game now always uses dx9. Anyone else? --Gem-icon-sm.png 01:15, 24 May 2006 (CDT)

Bump, this is killing me on some computers! --Gem-icon-sm.png 18:27, 3 June 2006 (CDT)
It works for me, wherever I put it in the command line. Maybe your dx8 installation is screwed or your video card drivers are not dx8 compatible?. --Ishmaeel 02:14, 4 June 2006 (CDT)
Are not dx8 compatible but are dx9 compatible? How is that possible? Well, it works on my other comp, but my laptop still doesn't allow the game to use dx8. Weird. It worked earlier. --Gem-icon-sm.png 04:56, 4 June 2006 (CDT)

Forgot to mention, I figured this out. The -dx8 only works if put as the first parameter. I have edited the article. --Gem-icon-sm.png (talk) 15:33, 1 August 2006 (CDT)

-image bugged?[]

i just liked to fully upgrade my game after nearly 2 weeks holyday, but the GW.exe has after a few seconds runtime 'no response' and needs 100% CPU... The preceding unsigned comment was added by HJT (contribs) . 15:17, 1 August 2006 (CDT)

i've noticed the opposite, that -image now no longer downloads anything, and jumps straight to the login screen. i'll make a more difinitive test later. --Honorable Sarah Honorable Icon.gif 15:36, 1 August 2006 (CDT)
Worked for me. It reportedly downloaded about 21k files. Took about ten minutes and the window did stop painting occasionally. I didn't try to close it, but I suspect Windows would have told me it wasn't responding if I had. Running it a second time just popped the update window up for a moment and then closed it, like the article implies will happen. -- 16:43, 1 August 2006 (CDT)
Honorable Sarah: If you have any other parameters, before or after the -image, the -image is ignored. --Gem-icon-sm.png (talk) 21:08, 1 August 2006 (CDT)

-heapsize removed[]

User:Patrick Wyatt removed the - heapsize command. Isn't this a working command? --Gem-icon-sm.png (talk) 07:25, 13 August 2006 (CDT)

Apparently, the devs have surgically removed the heapsize from the executable. Below are the only command strings that can be found in the gw.exe:
  • diag
  • dx8
  • email (not working)
  • fps
  • image
  • map (unknown)
  • password
  • perf
  • port (unkown)
  • repair
  • noshaders
  • nosound
  • mute (new addition, unknown)
  • noui
  • uninstall
  • update
  • windowed
The discussion over at that ST47 refers to is kinda outdated already. The main post gets updated from time to time by the OP but the rest of the discussion should be taken with a grain of salt.--Ishmaeel 03:51, 15 August 2006 (CDT)
How were these determined? Most (if not all) of those don't appear as ASCII strings in the executable in a way that suggests they're parameters. -- 04:09, 15 August 2006 (CDT)
They appear as UNICODE strings in the executable. A decent hex editor with unicode string search capabilities will find them. Just search for "nosound" (this word does not appear anywhere else) and you'll see all the params in a happy little clump.--Ishmaeel 04:20, 15 August 2006 (CDT)
Don't forget that the user Patrick Wyatt is one of the cofounders, so he can be trusted :)
You can't know if the wiki User:Patrick Wyatt is the real one, or an imposter. --Gem-icon-sm.png (talk) 16:42, 28 August 2006 (CDT)

Verified with diagnostic program. The -heapsize argument didn't change the allocation of the heap one bit. — Galil Ranger 16:51, 28 August 2006 (CDT)

I'm not sure that heapsize not existing in the program means anything. Heapsize is not something that the Guild Wars program has to worry about; Windows assigns the program it's memory before its started - hence it's an option for Windows for Guild Wars. Lots of programs have this option. YMMV. Galil, not that I'm doubting you, but could you give us the numbers you were working with? --MasterPatricko 13:27, 29 January 2007 (CST)
Windows does not have any mechanism that would allow it to capture the arguments passed on to any application and launch it accordingly. If something should happen in response to a command line argument, that something MUST be made to happen by the application itself and nothing else. Any argument that is ignored by the application is...well, ignored. Granted, it could be possible that the argument string be not visible in the executable (compressed/encrypted binaries come to mind) but in the case with GW.EXE, all the other params are out in the open, why would this be any different?--Ishmaeel 07:47, 31 January 2007 (CST)
Actually, you can't have any numbers, since I don't have them any more. I wrote that in August after all. If I remember them correctly though, at the login screen 58 MB was allocated on the heap for Gw.exe, while after adding -heapsize 256000 at the command line, it was still 58 MB. Also, as Ishmaeel said, windows doesn't take any arguments into its own use (with the exception of /prefetch:1 which makes sure the Prefetcher is used for that program). If it's not implemented by the programmer, it's simply not there. — Galil Ranger 08:41, 16 February 2007 (CST)
Galil, your final sentence is correct AND/BUT there are no exceptions. See here : --Ishmaeel 15:02, 16 February 2007 (CST)000621.html
I admit I was wrong in my statement, but I wasn't wrong in saying the prefetch-parameter is used by the OS, cause indeed it is. Quote from the very link you gave me, by Ryan Myers: "The /prefetch:# flag is looked at by the OS when we create the process — however, it has one (and only one) purpose. We add the passed number to the hash.". I've verified this to be true.
As the experimental executable, I took an assembly written by myself, and I can assure you it takes no command line parameters. The only thing this program does is test my MainLoop class that I wrote earlier today cause a friend needed it. The assembly name is "test.exe" and when run, it gets its own nifty file in the Prefetch-folder. When run again, no additional .pf-file is created since there already exists one for that assembly. However, when you add /prefetch:1 as a parameter, you get two .pf-files. The one you already have and a new one, since it added 1 to the hash. If I run it again with /prefetch:9, I end up with three files. Any other parameter is ignored by both the OS and my program, and does not create an additional prefetch-file. So I was correct that the /prefetch is an exception and is indeed used by the OS, just not for what people generally tend to think. It's just a mechanism for developers to be able to use different .pf-files for different situations. — Galil Ranger 23:35, 24 February 2007 (CST)
Oh. Another undocumented and unsupported tweak to make it seem an MS product is performing better -- well, at least this one is open to other applications too. I should stop being a smartypants -- those sneaky guys are out to prove false everything I know! :P (Or I could be grateful that one learns something new everyday, but that would be against the IT code of arrogance). Thanks for pointing me to the Ryan's update. It wasn't there when I posted the link.--Ishmaeel 01:16, 25 February 2007 (CST)

new params[]

I was intending to re-check the exe for some time now. I was finally compulsed (itaw?) with the addition of "-bmp". Below are my new findings. Speculate away!--Ishmaeel 20:44, 19 January 2007 (CST)

  • authsrv (unknown)
  • bmp (yeah)
  • mce (huh?)
  • newsound (sounds new) - nevermore!
  • exit (thought it would terminate a running instance but it doesn't)


Will this remove almost all loading time alltogether for guild wars and areas? I hope so, and if it does it's highly useful...Im playing a shooter while guild wars downloads so 41k odd files. 28.8k remaining! :-)

Blastedt 13:50, 16 September 2006 (CDT)

It removes all file loading and decompression from the game. However, on a low machine the loading screen might not update to the game screen as fast as you might like. --Gem-icon-sm.png (talk) 15:44, 16 September 2006 (CDT)
46394 Files remaining XD only at 1% lol, should probably be done around 4 or 5 hours -.- 20:20, 9 April 2008 (UTC)


Can you have multiple of thses like pass word and image for instance? If you can, How do you do it?Two thousand health 20:14, 27 December 2006 (CST)

Yes yo ucan. Just put them all after each other, with a space between them. Some of these only work if they are listed first, last or alone, but those are mentioned in the article. --Gem-icon-sm.png (talk) 20:33, 27 December 2006 (CST)

Broken DL on -image[]

Anyone have this before when using -image afetr a previous one was broken by loss of internet? My lappy had gone stand-by due to unuse, and the internet went off during an image :(

Broken DL.jpgBlastedtSigleft.jpgBlastedtBlastedtSigright.jpg— 06:10, 12 January 2007 (CST)


Hmmkay, I think my GW is broken. It still saves screenshots as bitmaps, without me using this command. Not that I would mind, though, I just find it curious. --84-175 (talk) 11:07, 23 January 2007 (CST)

-bmp seems to work spurractically for me. like rigth now, i had typed in -bmp a long time ago, but GW was taking .jpgs. so i removed and re added -bmp earlier today, and was able to take needed screens as .bmp. but now with the -bmp command line in there its taking .jpgs again and everything i do doesnt work...

gw.dat size[]

My -image'd file is currently 3,489,781,760 bytes. Depending how you look at it, 3.25 or 3.49 gigs. --Fyren 06:12, 23 January 2007 (CST)

Hmmm ... it's weird. The file size seems to vary a lot, even for users who have the same campaigns on their account, do a clean reinstall or deleted and re-downloaded their gw.dat file. Maybe we should collect some statistics. --Tetris L 07:24, 23 January 2007 (CST)
Mine is currently 3,201,760,256 bytes (after the most recent -image), and with all three campaigns installed. I've never needed to rebuild my GW.dat file from scratch (although I have moved it to a second drive then back again in order to force it to defrag). I may try rebuilding it this week to see how big it is after doing that. --- Barek (talkcontribs) - 10:55, 23 January 2007 (CST)
3,260,863kb new hdd, new install, just last week, -imaged recent. -- Xeon 11:00, 23 January 2007 (CST)
Maybe it has to do with the number, type and curent location of your characters? Even though most of the character data are saved server side there may be things that are "cached" client side. Or it may also have to do with what edition of GW you have. --Tetris L 11:44, 23 January 2007 (CST)
Mine is bigger than your's: 3,951,219 KB. :p Now don't tell me size doesn't matter. ;) --Tetris L 14:15, 23 January 2007 (CST)
Kalomelis computer does weird things. She had ~4gig a month or so ago. Then we deleted gw.dat and run -image. The file was 5gig after that. We did the same again and that time we got a gw.dat of 7gigs. Then we removed the gw.dat, defragmented the harddrive, removed some 1-2gig files, defragmented again and then run -image. Now it's the normal 3gig. --Gem-icon-sm.png (talk) 05:03, 24 January 2007 (CST)
Defrag definetly is an issue here. I havn't done a defrag in ages, which may explain the rather large size of my dat file. OS may be an issue too, as file management and fragmentation of older OS (notably Win98) plain sucks. --Tetris L 05:07, 24 January 2007 (CST)
Hmm, wasn't their a glitch in gw a long time ago, where it would inflat the gw.dat file for no reason? -- Xeon 06:20, 24 January 2007 (CST)
Yes, there was (thread on guru). Supposedly it has been fixed almost a year ago. I have my doubts, though. On the other hand, fragmentation shouldn't have a large impact on file size either - at least from all I know about file systems. Fragmentation will result in something taking longer to load, because the heads have to move all over the place. But even with old and crappy file systems like FAT, it should still only use whole blocks, no matter where they are located on the disc, keeping slack for large files minimal. --84-175 (talk) 06:36, 24 January 2007 (CST)
Defrag won't directly impact the gw.dat file (The windows defrag tool won't defrag files over a certain size - and gw.dat far exceeds it). But if you defrag the other files on the drive, then rebuild (or move) the gw.dat file will build it with few to no fragments. --- Barek (talkcontribs) - 11:03, 24 January 2007 (CST)


I would like to point out that actual file system fragmentation is completely transparent to individual applications. They still see the files as contiguous blobs of data -- they only access it slower. For this reason, GW.DAT size should be totally unrelated to file system fragmentation. Now, fragmentation within the DAT file is another matter altogether. Since it is an archive format, the DAT file itself can be fragmented and the empty portions within the file can contribute to its size. And this fragmentation is invisible to the operating/file system in turn, so it cannot be fixed by using Windows' defrag utility. With this information and with no intention of disrespect to anybody, I'm proceeding to remove the note about defragging since it is simply misinformation.--Ishmaeel 07:13, 24 February 2007 (CST)

FPS lags[]

I tested the new -bmp with the old -password command line. So my file looked like this: ' "I:\GUILD WARS\Gw.exe" -bmp -password fluppe ' (note: it's not my real pw). Tested this for two days. The logins worked as expected (so nice) but the whole game wasn't nicely playable anymore. My FPS jumped every second from down to high, e.g. 31 FPS in one second and 7 FPS in the next, then 10 FPS, 24, 12, 10, 6, 29 etc. Was no fluid gameplay, all laggy. Annoying. Ping was normal (150-350 ms). Now after deleting the '-password' command, only leaving the '-bmp' everything is back to normal. Does/Did anyone else experience it too? --Birchwooda Treehug 09:47, 23 January 2007 (CST)

Check your computer for viruses and spyware and then report this to anet [1]. -- Xeon 11:03, 24 January 2007 (CST)

Sound commands[]

See Gailes post at GWWiki. As far as I understood correctly, those command line arguments have been added to the game. --Gem-icon-sm.png (gem / talk) 04:31, 8 April 2007 (CDT)

The following really are in the executable, and the "newsound" seems to have been removed. Haven't done any testing -- mainly because I am tone deaf.
  • sndasio : (ASIO driver software mode?)
  • sndwinmm: (Windows multimedia audio driver?)
  • dsound : (old DirectSound software mixer?)
BTW, the latest version is occasionally causing horrible echoing effects that actually lag the game for a few seconds for me. Maybe I'll be using -dsound for a while. --Lazyeyes.pngIshmaeel .ping( ) ; .peek( ); 16:22, 10 April 2007 (CDT)
Glad to know I'm not the only one. I've gotten that broken record effect, too, particularly when first engaging an enemy in battle. 07:51, 13 April 2007 (CDT)


Any possibility to add the email to the commandline? Since I've 2 GW accounts it would be handy to create 2 shortcuts to the GW.exe with each email and password for one account. Or if anyone knows an easier solution than the current one to type the mail by hand every and every time again -.- --Birchwooda Treehug 10:25, 24 May 2007 (CDT)

Apparently, once there was an option for that, but it got removed at some point, perhaps due to security considerations. Since the game saves the last used e-mail in the gw.dat file, the only way to automate this would be using loader applications that could send keystrokes. --Lazyeyes.pngIshmaeel .ping( ) ; .peek( ); 10:39, 24 May 2007 (CDT)
Heads up: E-Mail parameter has been added back. Yay! --Lazyeyes.pngIshmaeel .ping( ) ; .peek( ); 05:59, 2 June 2007 (CDT)
I've been using Keepass to type login info for me (for 3 account) for about more than one year now and i prefer that to using -email anyway. It's cool they added it back. Don't know why they remove it in the first place... §: TůζipVõrζąx Talk 16:41, 3 June 2007 (CDT)
KeePass rulaz! --Lazyeyes.pngIshmaeel .ping( ) ; .peek( ); 18:28, 3 June 2007 (CDT)
One of my guildies said that he has been using -email for as long as many months now. It seems that adding back this features is not as recent as we though. §: TůζipVõrζąx Talk 20:21, 5 June 2007 (CDT)
I see, maybe it wasn't in the documentation then. I never tried it because I didn't know that command :P (even when it's quite obvious) ;) Isn't KeePass just a password manager? Not like I would forget my e-mail and password for both GW accounts :P Just a hassle to type it in everytime. --Birchwooda Treehug 07:32, 17 January 2008 (UTC)
KeePass has an auto-type feature. You press a key combination and KeePass looks at the title of the active window and types in the correct username and password for you. –IshmaeelLazyeyes.pngping/peek 09:04, 17 January 2008 (UTC)


From what I can tell, -mce starts gw within Windows Media Center (Vista only). For some reason, this also seems to be the default when installing GW on Vista (the installed shortcut has that option on install). From what I could tell, setting up the Media Center correctly then make GW use digital sound output (that's what it did here, instead of using the default sound output). --Theeth Assassin (talk) 22:57, 16 June 2007 (CDT)

Yes, the Media Center thing was known, but, since it is already taken care of automatically where necessary, and since it has virtually no practical use for the end user, it was omitted from the documentation. At least that's what I thought while I wasn't adding it to the article. I'm not entirely sure what you mean by digital vs default sound output though. If it does have an effect on non-Vista systems, we might as well document it, but personally, I doubt that it has anything to do with the sound system.--Lazyeyes.pngIshmaeel .ping( ) ; .peek( ); 06:24, 17 June 2007 (CDT)
It's included by default in Windows 7. Kaede 21:45, 11 May 2009 (UTC)


Does -bmp entail anything OTHER than just saving screenies as .bmp rather than .jpg? No added download time, no higher game quality, just screen shot improvements? Glimmer of Light.jpg The Paintballer (T/C)

Yep. Just the screenies. --–IshmaeelLazyeyes.pngping/peek 00:42, 7 August 2007 (CDT)


Any source on that info that this was designed to use GW as a screensaver? Without any source it looks more like a users opinion instead. --- :Jill Bioskop X(T|C) 07:52, 31 August 2007 (CDT)

Works with Vista?[]

I can't seem to find gw.exe under properties to change it, specifically for my password, any idea where they are? Nilator 20:39, 7 April 2008 (UTC)

Make a shortcut, then hit properties on it. It should say "C:\Program Files\Guild Wars\Gw.exe" Just make it so it says
"C:\Program Files\Guild Wars\Gw.exe" -(command) 20:19, 9 April 2008 (UTC)

copying GW folder to laptop[]

I know most people would say to go ask official support about this but i'm pretty sure they'll say to try installing it the normal way.

The thing is, i recently changed hard drive of the laptop wich had GW installed and running normally before this. Tonight i needed to do an exchange between two of my accounts so i've copied Guild Wars folder that was on my regular computer to an external hard drive (the ancien laptop hard drive in a new external case) and then copied it over the laptop.

I've used the repair function on the laptop. But i forgot to unplugged the external drive, so it was the wrong copie that got installed. No problem, i've deleted every GW things from the registry. Reinstalled the game to the proper location (for me it's always in drive E:) and then i've run it and proceed with the exchange.

But, now that GW installation is always starting in Fullscreen 1024x768 even with the -windowed parameter. It bugged me or so. I dont understant why. I've tried reinstalling the game using the client download from the official site but it want to download the whole dat file again so i stop it after like 5 Mo and copy my 3.69 Go dat file over the new one. But it still insist on going in full screen.

What a weird thing. Otherwise, it run well enough to serve my needs of doing trade between my differents accounts. — TulipVorlax 02:12, 3 August 2008 (UTC)

I've uninstalled it and reinstalled using the CDs of the first campaign. Before the end it wanted to download more than 5000 files (again) so i closed it. I've copied over the .dat file again. The game run as well as every times but i still can't get him to stay in windowed mode even using the command line parameter. — TulipVorlax 23:39, 3 August 2008 (UTC)

Recent edit[]

[2]. I have no idea what to do with it tbh. I don't know what the function does, nor is it really clear to me reading what used to be there. --- Ohaider!-- (s)talkpage 14:43, 27 August 2008 (UTC)


it seems like this does not work with texmod? Dumbo Ranger-tango-icon-20.png 22:12, 16 May 2009 (UTC)

No, it does not. Just like with any other 'loader' type of program.Setsune 02:24, September 9, 2009 (UTC)

auto-login help[]

I can't get it to work. My shortcut is (fake ofc but for the sake of example):

"C:\Program Files (x86)\Guild Wars\Gw.exe" -email -password ImSo1337 -character Rose Of Kali

What did I do wrong? It brings up a screen with a login error. The email field is filled, pw field is empty, and character field has "Rose" only. RoseOfKali RoseOfKaliSIG.png 15:35, December 23, 2009 (UTC)

Lol ok, missed quotes around character name. ^_^; RoseOfKali RoseOfKaliSIG.png 15:43, December 23, 2009 (UTC)

Batch Files[]

I created a text file, renamed it something.bat and filled it with the following lines

cd "C:\Program Files\Guild Wars"
start Gw -character "Lul Zes"

I can't remember how to specify the dir to start from without using the cd command first; is there a way to do something like:

start "C:\Program Files\Guild Wars\Gw.exe" -character "Lul Zes" 

Noman Nomansig.png (talk | contribs) 20:41, December 23, 2009 (UTC)

It might be easier just to create windows shortcuts.
e.g. for getting updates, I use Update Gw shortcut, which has a target of:
"C:\Programs\Guild Wars\Gw.exe" -image
e.g. I use Captain Kirk logon, which as a target of
"C:\Programs\Guild Wars\Gw.exe" -email -password InSecure -character "Captain Kirk" -perf -windowed
You can leave off the email/pw if desired.   — Tennessee Ernie Ford (TEF) 20:59, December 23, 2009 (UTC)
Found the command I was looking for:
path C:\Program Files\Guild Wars;%PATH%
start Gw.exe -character "Lul Zes"Noman Nomansig.png (talk | contribs) 05:04, January 9, 2010 (UTC)

mute and nosound[]

GWW says the exact opposite of what this says, the functions for mute and nosound are reversed. Which is correct? --Macros 18:55, January 4, 2010 (UTC)

Just by the names it would appear that our version is wrong, but I don't know for sure. RoseOfKali RoseOfKaliSIG.png 19:16, January 4, 2010 (UTC)
A good way to test the GWW's version would be viewing the cinematics with both switches. If they got the difference right, lip syncing should not work (correctly?) with one of the switches. Neither of them messes with the volume in the configuration screen though. If any of them "sets the volume to zero", it works as an override. –IshmaeelLazyeyes.pngping/peek 12:27, January 5, 2010 (UTC)